Share

October 10, 2008

MyEclipse 6.5 support is not backward compatible with Eclipse and m2eclipse

My team has been using MyEclipse as an IDE but running MyEclipse 6.5 does not have a good support for Maven.

The Maven4MyEclipse that comes with MyEclipse 6.5 does not support the projects created with the m2eclipse plugin. I think Eclipse 3.4 with m2eclipse is much better editor for Maven Users...

4 comments:

  1. You may want to look at my blog about this. We have provided a workaround to allow to use genuine m2eclipse with myeclipse.

    ReplyDelete
  2. eugene,

    would love to know more what is the url to your blog

    ReplyDelete
  3. Guys;

    MyEclipse 7.0M2 and the soon-to-be-released 6.6 (for Europa users) includes a full implementation of m2e, and allows users to choose either a more guided version using Maven4MyEclipse, or the raw m2e plugin. The choice is yours.

    Cheers,
    Jens
    Genuitec

    ReplyDelete
  4. jeckels,

    you are right, i can use MyEclipse 7.0M2 with m2eclipse and that works...

    Note: m2eclipse it is not part of MyEclipse you will Need to install it 1st.

    ReplyDelete