Share

August 31, 2009

Apple Snow Leopard != Happy Parallels Desktop

I bought Parallels Desktop while back and returned it since it did not work will for me, then I switched to VMWare. Today I'm extra happy that i no longer used it as i got the following in an email.




Planning to upgrade to Apple's new Snow Leopard OS?
You'll need to upgrade to Parallels Desktop 4.0 for Mac.


We would like to let you know that your current version of Parallels is not compatible with Apple's new Snow Leopard operating system. To make your transition to Snow Leopard easy, we are offering a special upgrade price for the compatible version, Parallels Desktop 4.0 for Mac. As a registered user, you are entitled to save over 50% off the normal price. Only $39.95.
This is a limited time offer. To claim your special upgrade price simply click the links below.

WHAT....  I have to pay... no free fix? BOOOOOOOOOO