Share

March 29, 2011

Maven: version your maven-surefire-report plugin



If you get the following error while doing a deployment of the maven site... you may have a surefire plugin that is not version-ed.


The following is from the plugin's site

Note: As of version 2.8 this plugin requires Maven Site Plugin 2.1 or higher to work properly. Version 2.7.2 and older are still compatible with newer surefire versions, so mixing is possible.






I used the following to fix it